Jump to content

Welcome to Vectra Klub Polska

Guest Image

Welcome to Vectra Klub Polska , like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Vectra Klub Polska by signing in or creating an account.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.

Nie odpala, błędy w komunikacji CAN


Recommended Posts

Witam wszystkich, moje kapryśne auto nie lubi chłodu i wilgoci. Czasami nie reaguje na pilot i próbę odpalenia. Jak postoji i słoneczko przyświeca to odpali. Czasami wzbudzi się po odłączeniu Aku. Czasami w czasie jazdy też się wyłącza komp, ale wtedy wszystko się wyłącza ale silnik i wspomaganie nadal pracuje. Reszta znika na chwilę. Najczęściej pomaga naciśnięcie (muśnięcie) hamulca. Zrobiłem zdjęcie podłączonego interfejsu podczas gdy auto się zawiesiło. W którym kompie szukać przyczyny. Może wiązka gdzieś siada? Cim sprawny, zegary też jak by co.

 

Vectra c 1.8xer 2007

IMG_20201010_132934.jpg

Edited by cypek
Link to post
Share on other sites

Zeskanowałeś ilość błędów w modułach, a odczytałeś co to za błędy? CIM piszesz, że jest sprawny, a jak dobrze widzę jest 18. Pokaż je nam jak i inne.

Edited by Cretux
Link to post
Share on other sites

DIAGNOSTIC REPORT:
VAUX-COM 120309a

Please add your workshop
name in the settings window

**********************ECU ID STARTS**********************
Source Address: CIM
Identifier: 0x0015
VIN: W0L0ZCF6881046911

Number of stored fault codes: 9

B3715 - CAN-Bus No Communication with UEC (Underhood Electrical Centre)
(00)  - Not present

B3924 - Wrong Environment Identifier Received BCM (Body Control Module)
(00)  - Not present

B3926 - Wrong Environment Identifier Received DDM (Driver Door Module)
(00)  - Not present

B3927 - Wrong Environment Identifier Received PDM (Passenger Door Module)
(00)  - Not present

B3929 - Wrong Environment Identifier Received REC (Rear Electrical Centre)
(00)  - Not present

U2107 - CAN-Bus no Communication with BCM
(00)  - Not present

U2117 - CAN-Bus No Communication with DIS (Display)
(00)  - Not present

U2141 - CAN-Bus No Communication with REC (Rear Electrical Centre)
(00)  - Not present

U2113 - CAN-Bus No Communication with SDM (Sensing & Diagnostic Module, Airbag)
(00)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: ECM
Identifier: 0x0F22
VIN: W0L0ZCF6881046911
System name: Z18XER

Number of stored fault codes: 4

P1614 - Wrong Transponder Key
(50)  - Not present

P1616 - CIM (Steering Column Module) Wrong Environment Identifier
(00)  - Not present

P2120 - Accelerator Pedal Position Sensor 1 Voltage Low
(06)  - Not present

P2125 - Accelerator Pedal Position Sensor 2 Voltage Low
(06)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: ABS/TC/ESP
Identifier: 0x6003

No fault codes stored.

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: EHPS
Identifier: 0x0104

No fault codes stored.

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: IPC
Identifier: 0x1203

Number of stored fault codes: 5

U2107 - CAN-Bus no Communication with BCM
(00)  - Not present

U2117 - CAN-Bus No Communication with DIS (Display)
(00)  - Not present

U2141 - CAN-Bus No Communication with REC (Rear Electrical Centre)
(00)  - Not present

U2113 - CAN-Bus No Communication with SDM (Airbag)
(00)  - Not present

U2140 - CAN-Bus No Communication with UEC (Underhood Electrical Centre)
(00)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: AIRBAG SDM
Identifier: 0x0102

Number of stored fault codes: 2

U2116 - Invalid Data from IPC (Instrument)
(00)  - Not present

U2139 - Invalid Data from CIM (Steering Column Module)
(00)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: BCM
Identifier: 0x0209

Number of stored fault codes: 3

B2955 - Anti Theft Warning System Sensor Datalink Circuit Low Voltage or Circuit Open
(06)  - Not present

B2955 - Anti Theft Warning System Sensor Datalink no Communication
(0F)  - Not present

B3078 - Anti Theft Warning System Horn Signal Circuit Low Voltage
(02)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: REC
Identifier: 0x0105

Number of stored fault codes: 2

U2139 - CAN-Bus No Communication with CIM (Steering Column Module)
(00)  - Not present

B0283 - Rear Window Heater Low Voltage or Circuit Open
(06)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: UEC
Identifier: 0x0105

Number of stored fault codes: 2

U2139 - CAN-Bus No Communication with CIM (Steering Column Module)
(00)  - Not present

B1375 - Switched System Voltage (Ignition ON) Circuit Malfunction
(00)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: DDM
Identifier: 0x0106

Number of stored fault codes: 3

B3797 - Driver Door Deadlock Motor Circuit Open
(04)  - Present

U2139 - CAN-Bus No Communication with CIM (Steering Column Module)
(00)  - Not present

B1330 - System Voltage Malfunction
(00)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: PDM
Identifier: 0x0105

Number of stored fault codes: 3

U2139 - CAN-Bus No Communication with CIM (Steering Column Module)
(00)  - Not present

B1330 - System Voltage Malfunction
(00)  - Not present

B1325 - System Voltage Low Voltage
(03)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: ECC
Identifier: 0x0201

Number of stored fault codes: 1

B3843 - Air Quality Sensor Circuit Open or High Voltage
(05)  - Intermittent

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: EHU
Identifier: 0x0505

Number of stored fault codes: 1

B1245 - CD-Changer Malfunction
(00)  - Not present

**********************ECU ID ENDS**********************

**********************ECU ID STARTS**********************
Source Address: DIS
Identifier: 0x1401

No fault codes stored.

**********************ECU ID ENDS**********************

 

Link to post
Share on other sites
2 godziny temu, Cretux napisał:

Zeskanowałeś ilość błędów w modułach, a odczytałeś co to za błędy? CIM piszesz, że jest sprawny, a jak dobrze widzę jest 18. Pokaż je nam jak i inne.

Cim był wymieniany testowany i podmieniany. Nie ma wpływu na usterkę. Zegary również.

Link to post
Share on other sites
8 godzin temu, cypek napisał:

Nie łączy się ponieważ siada linia can.

U mnie nic nie siada i też nie widzi  wszystkich modułów np.BCM

Link to post
Share on other sites
1 godzinę temu, darioG73 napisał:

U mnie nic nie siada i też nie widzi  wszystkich modułów np.BCM

W raporcie mam wszystkie moduły ponieważ zrobiłem to po odwieszenie się. Problemem nie jest op-com. Szkoda że to stało się przedmiotem dyskusji.

Link to post
Share on other sites

Nie bardzo się orientuję przy CIM, ale wydaję mi się, że może gdzieś na jakieś kostce czy wiązce dobrze nie łączy i są przerwy. Wg mnie trzeba byłoby dobrze się przyjrzeć instalacji

Link to post
Share on other sites
1 godzinę temu, Cretux napisał:

Nie bardzo się orientuję przy CIM, ale wydaję mi się, że może gdzieś na jakieś kostce czy wiązce dobrze nie łączy i są przerwy. Wg mnie trzeba byłoby dobrze się przyjrzeć instalacji

Tylko gdzie szukać. Magistrala jest szeregowa. Więc może któryś z tych modułów jest pierwszy i wtedy zawęzi się pole poszukiwania wan do krótkiego odcinka. Ostatnio wykopem uec i tam nie widziałem żadnych problemów z wiązkami. 

Link to post
Share on other sites

Po błędach wychodzi na to, że moduły, które wypadły z linii CAN w wyniku "zwiechy" mają głównie problemy z CIMem. Może i sam CIM jest dobry ale ja bym sprawdził wiązkę począwszy od CIMa. Może sama kostka nie kontaktuje. Nie mam niestety TIS'a ale znaleziony obrazek z elektrody kawałek schematu sugeruje raczej równoległy charakter podłączeń do magistrali (jak źle mówię, to spalcie mnie :P). Może któreś złącze główne w aucie jest zamoczone/zaśniedziałe np. X1. albo weryfikacja każdej z kostek na drodze CIM - moduły. Jeśli jednak jest szeregowa to najbliższym sąsiadem wydaje się BCM.

 

Edited by kacp3r
Link to post
Share on other sites
1 godzinę temu, kacp3r napisał:

Po błędach wychodzi na to, że moduły, które wypadły z linii CAN w wyniku "zwiechy" mają głównie problemy z CIMem. Może i sam CIM jest dobry ale ja bym sprawdził wiązkę począwszy od CIMa. Może sama kostka nie kontaktuje. Nie mam niestety TIS'a ale znaleziony obrazek z elektrody kawałek schematu sugeruje raczej równoległy charakter podłączeń do magistrali (jak źle mówię, to spalcie mnie :P). Może któreś złącze główne w aucie jest zamoczone/zaśniedziałe np. X1. albo weryfikacja każdej z kostek na drodze CIM - moduły. Jeśli jednak jest szeregowa to najbliższym sąsiadem wydaje się BCM.

 

Super schemat ale potrzebny cały żeby coś znaleźć w tym wypadku. Może ktoś ma?

Link to post
Share on other sites
14 minut temu, cypek napisał:

Może ktoś ma?

Na forum są linki do TIS 2000 czy Autodaty, więc można sobie ściągnąć i zainstalować

Link to post
Share on other sites
  • 3 weeks later...
Dnia 15.10.2020 o 14:01, Cretux napisał:

Na forum są linki do TIS 2000 czy Autodaty, więc można sobie ściągnąć i zainstalować

Dzięki za rady. Przesledzilem linie can i znalazłem że problem jest od bcm do zegarów. Wyczyściłem płytkę całą w zegarach i wszystkie styki w bcm. Auto działa bez problemów. Usunąłem też potencjalny przeciek z linki do otwierania maski. Mogło kąpać wprost na wtyczkę z bcm. ( TIS dał radę )

Edited by cypek
Link to post
Share on other sites
  • 2 weeks later...

Hej, podłączę się do tematu. Mój problem polega na tym, że czasem przekręcam kluczyk - zapłon wszystko działa 1 - 2 pozycja, próbuję odpalić i żadnej reakcji nie ma. Rozrusznik nawet nie kręci. Niekiedy odpali dopiero za 2-3 przekręceniem kluczyka. Boję się, że kiedyś wgl. nie odpalę. Zdarza się to sporadycznie, coś jak raz na 2-3 tyg. Nie wiem, czy to wina stacyjki (już ją czyściłem, ale nie działa już tak lekko jak kiedyś), lub nie wiem... Może rozrusznik się zacina? 

Link to post
Share on other sites
  • 3 weeks later...

Przeczyściłem specjalnym środkiem, tak kilka tyg. temu. Nie było problemu, ale ostatnio coś 3 razy musiałem próbować, dziś rano dopiero za 5 zaskoczył. Normalnie mam wszystkie ikony na desce, akumulator na pewno jest okej, kręcę kluczykiem i nic... Tylko jakiś dziwny dźwięk pod maską, ale nawet nie próbuje zakręcić. Ogólnie jak "działa" to kręci bardzo ładnie, rozrusznik wydaje się być w dobrej kondycji. Ps. błędów żadnych nie ma, ale jakoś tak człowiek rano - zaspany i nie słuchałem, czy pompa paliwa działa, czy ją odcina. Rozumiem, że przyczyną często bywa wilgoć w kostce od ABS?

Edited by Ronal
Link to post
Share on other sites

Teraz mam to już co - każde poranne uruchamianie. Jak się zrobiło zimno, to właśnie nie kręci nic - tylko się dławi coś pod maską (tak jakby) dziwny dźwięk. Ale zawsze odpali po jakimś czasie, albo kilku próbach. Przejrzę jeszcze raz kostki. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
UP